Unable to Cancel Call

Apr 25, 2014 at 6:23 PM
I am trying to host local version (build using latest source code) in windows azure. Everything is working except call will not get cancelled if either of the end hangup. Same issue is in AWS also. Is there any specific port which I need to open? In AWS I opened all ports but still not working. The same build works in another VPS server without any issues.

Can you please help me to solve this issue?

Thanks,
Plachira
Developer
Apr 27, 2014 at 7:56 PM
Edited Apr 27, 2014 at 7:58 PM
Hi Plachira,

Are you seeing BYE messages in SIP Sorcery?
Apr 27, 2014 at 9:09 PM
Hi Skrusty,

I am not seeing BYE messages. Instead it is timing out around 10 seconds after hangup. BYE messages are seeing if I host in standalone VPS other than AWS or Azure.
Developer
Apr 28, 2014 at 8:20 AM
And you have port 5060 UDP (Assuming you're using UDP) open on the AWS security group yeah?
Coordinator
Apr 28, 2014 at 11:50 AM
Have a look at the SIP Proxy runtime script, it's called proxyscript.py and will be in the same directory as the exe you are running the server from. The values for the m_proxySocketInternal and m_appServerSocket variables should be set to the private IP address of your AWS instance.
Apr 28, 2014 at 11:30 PM
aaronc wrote:
Have a look at the SIP Proxy runtime script, it's called proxyscript.py and will be in the same directory as the exe you are running the server from. The values for the m_proxySocketInternal and m_appServerSocket variables should be set to the private IP address of your AWS instance.
I have changed m_proxySocketInternal and m_appServerSocket from 127.0.0.1 to private IP address. Now the issue is call is not connecting. Following message is repeated in the console.

DialPlan 23:24:10:325: req INVITE from=admin, to=[number], udp:107.130.xx.xx:5062
DialPlan 23:24:10:825: req INVITE from=admin, to=[number], udp:107.130.xx.xx:5062
DialPlan 23:24:11:825: req INVITE from=admin, to=[number], udp:107.130.xx.xx:5062
DialPlan 23:24:13:809: req INVITE from=admin, to=[number], udp:107.130.xx.xx:5062
DialPlan 23:24:17:825: req INVITE from=admin, to=[number], udp:107.130.xx.xx:5062
Developer
Apr 29, 2014 at 7:54 AM
Edited Apr 29, 2014 at 7:56 AM
I found (with AWS) you need to set (in the app.conf file):

PublicIPAddress to your AWS instance Public IP (not private IP)
Enable STUNServerHostname as stun.counterpath.com

And depending on if you're using AllInOne or seperate exe's on difference machines, then yeah, set the m_proxySocketInternal and m_appServerSocket variables to the private IPs.

Also, make sure that the EC2 instances can talk to each other on the private IPs!

Then it worked fine.
Marked as answer by plachira on 4/29/2014 at 8:35 PM
Coordinator
Apr 29, 2014 at 11:18 AM
The public IP address and/or STUN settings as mentioned by skrusty are important for setting the correct IP addresses in the SIP headers and SDP. If the problem is BYE requests then that could be the issue. Try putting reversing the previous changes I suggested in the proxyscript.py file and setting the PublicIPAddress in your config file.

If the issue is CANCEL requests (which is what I assumed when I first read the initial post) then the PublicIPAddress setting won't solve it but perhaps by "cancel" you do mean hangup which is a different SIP request type and is made all rather confusing by SIP terminology.
Marked as answer by plachira on 4/29/2014 at 8:35 PM
Apr 29, 2014 at 1:53 PM
Thanks a lot for your help. Now we are almost there. CANCEL request is working fine. Seeing CANCEL request in console when I dial a number and hangup before it is connected.

I am able to see BYE message in console. But seeing a message "No dialogue matched" and call is not disconnected.

DialPlan 13:46:27:460: req BYE from=2066820185, to=username, udp:66.54.xx.xx:5060
DialPlan 13:46:27:725 20668xxxxx: No dialogue matched for BYE to sip:54.187.xx.xx:5060.

Can you please help?
Developer
Apr 29, 2014 at 3:09 PM
Unsure...

Out of interest, is there a matching dialogue in the table? You should be able to see a matching dialogue in your database.
Marked as answer by plachira on 4/29/2014 at 8:35 PM
May 1, 2014 at 6:03 AM
skrusty wrote:
And you have port 5060 UDP (Assuming you're using UDP) open on the AWS security group yeah?
Can you please let me know the ports which we need to open for default configuration? I assume following -

TCP - 80
TCP - 8080
TCP - 443
UDP - 5060
Developer
May 1, 2014 at 8:21 AM
That should be it.